Properly detect effects which need OpenGL 2
author Martin Gräßlin
()
committer Martin Gräßlin
()
commit db42152def79381547965eaadb3771f0d2fe908c
tree c82b92e4afe9c0960364056835f398698acd1ae0
parent 4d39db624571600d41bb0fa2149f774cbc67a5dc
Properly detect effects which need OpenGL 2

Effects that need GLSL require that OpenGL 2 is active.
It does not matter whether the GPU would support it if
OpenGL 2 is not used.

BUG: 299426
FIXED-IN: 4.8.4
REVIEW: 104848
kwin/effects/explosion/explosion.cpp
kwin/effects/invert/invert.cpp
kwin/effects/lookingglass/lookingglass.cpp